Home | About | Tournament Winning Decklists | Forums

Stimhack.com certificate needs updating?


#1

Chrome keeps giving me warnings about Stimhack being unsafe when I try to come to the main page.

Nerds who know tell me this is just a problem with the sites certificate being out of date.

On a different computer, I get a message that says my computer’s data and time are wrong and so I can’t go to Stimhack.com.

Just raising this here because I’m not sure who to notify or raise this with.


#2

Works fine on all my computers using Chrome. Do you have a cracked piece of software running a sanbox that messes with your internal clock to exploit a timed trial? I had that happen once. It was changing my internal time to something that didn’t match within the parameters of the security certificate. The cert has both a start and end date, so if your comp’s internal time is not within those dates, it will throw an error.


#3

If I had any idea what you just wrote, I could perhaps answer the question. The computer that gets the time/date error message is my desk top at work. My lap top just sends a message that says the certificate expired several days ago and the site is not safe but I can proceed at my own risk.


#4

I get the same messages as fightingwalloon that’s on chrome on linux and on Firefox on Android.


#5

Yep, I get the certificate warning here as well.


#6

None on Safari. MacBook.


#7

I see this warning.

A few notes for those who don’t see it: this is only affecting stimhack.com, not the forums; if you’ve ignored it once in Chrome, it does become a smaller warning in the address bar, which might be easier to miss; the advanced part of the warning on Chrome does include the date according to it, so you can confirm that the problem isn’t as Dstinct described, and it does show the correct date on my computer.


#8

Yeah they use one of the let’s encrypt SSL certs, they expire after a month and need an active refresh from the sites admins.

so just wait and ignore the warning
until they fixed it :wink:


#9

Ah. In that case, I wish them the best of luck in getting one of the auto-renewing setups going someday. :smiley:


#10

Noticed the same certificate if I use the HTTPS URL, so it makes sense that it’s a certificate issue. If I use HTTP in the address, obviously I won’t get a warning, but the links used on the main (non-forum) side mostly uses the HTTPS URL.


#11

How are you using HTTP? If I use HTTP, I get redirected to HTTPS.


#12

@zogstrip?


#13

I just have the articles page bookmarked without HTTPS (for example) that I check periodically: stimhack.com/category/articles

You may have a setting in your browser to always use HTTPS if available. I don’t think the site itself forces HTTPS (at least for the parts I tried).


#14

If somebody wants to set up auto-renewal in crontab w/ LetsEncrypt, the DigitalOcean docs have a pretty good approach for the cron job (assuming nginx):

# enter this
sudo crontab -e;
# and then add this line to the crontab
15 3 * * * /usr/bin/certbot renew --quiet --renew-hook "/bin/systemctl reload nginx"

Which means: At 3:15 AM every day, make Certbot check whether anything needs renewing. if anything updated, restart the reverse proxy service. Otherwise, do 0 things.


#15

Ah, that does work. Interesting!

The main site - http://stimhack.com - gives a 301 redirect to the HTTPS version.


#16

Ah okay. Yeah. I get it on the main site too. I never visit it, so I thought it was the forum that was being referred to which works fine for me and everyone else I assume. My bad. I just know that in the past I’ve used software hacks that alter the date on my comp to bypass time limit trials, and that can screw up certs by causing the date to conflict.