Home | About | Tournament Winning Decklists | Forums

OCTGN in Linux


#1

So, after seeing several people struggle with getting OCTGN to work under linux, I thought I would give it a whirl and write a small tutorial. Sources are at the end.

First things first

  • If you can, avoid using wine. Try installing an old windowsXP under VirtualBox. That’s how I run my OCTGN
  • If you have to use wine for whatever reason, try to stay away from codeweavers or playonlinux, and do it the old fashioned way
  • Seriously, just use a VM

I’m using the netinstall of Debian 8 64bit with no Desktop env. installed to start with. If you follow these steps, you should be able to get it to work on Debian,Mint,Ubuntu and other debian derivatives. Arch and other linux users should be able follow this tutorial as well, but might need to change things up a bit.

So, to start, install xorg and a DE/WM, in my case openbox. Note that if you follow me exactly, you will not have network drivers,graphic drivers or even sound. This is up to yourself

sudo apt-get update && sudo apt-get upgrade && sudo apt-get install xorg openbox

startx

to update the system and install a WM. Open up a terminal(in openbox, right click anywhere on the grey screen in front of you and select terminal emulator)

If you are on Debian, you need the contrib depository in order to install winetricks, which you need later on. I think this is already in the ubuntu ppa for wine, but I’m not sure. If your package manger won’t let you install winetricks, do a quick google search

sudo nano /etc/apt/sources.list

and edit the file(your mirrors are pbb different)

deb http://ftp.nl.debian.org/debian/ jessie main
deb-src http://ftp.nl.debian.org/debian/ jessie main

so it reads

deb http://ftp.nl.debian.org/debian/ jessie main contrib
deb-src http://ftp.nl.debian.org/debian/ jessie main contrib

Update the system and install all the parts needed

sudo apt-get update && sudo apt-get install wine winetricks winbind

Check the wine version

wine --version

Gives 1.6.2 in my case, but every wine above 1.5.4 should work. If it doesn’t, try to compile another wine, like 1.7.x

I’m on a 64bit system, so I want the 32bit architecture of wine

sudo -s

dkpg --add-architecture i386 && apt-get update && apt-get install wine32

exit

Make sure you exit, else you will be making your new wine prefix under root privileges!
Make a new 32bit wine prefix

WINEARCH=win32 WINEPREFIX=~/.wine-octgn winecfg

This will open up the cfg file, as well as a message that mono is not installed. DO NOT INSTALL MONO, it will break .NET framework later. If you did install mono, try to remove it or make a new prefix. do NOT install it.
In the cfg popup, make sure under applications it says Windows XP

Now, to install some components OCTGN needs

WINEPREFIX=~/.wine-octgn winetricks -q msxml3 vcrun2010 dotnet40

This will take a while, and alot of error and info messages will fill your terminal, don’t worry about it.

Now let’s download OCTGN

wget https://github.com/octgn/OCTGN/releases/download/3.1.190.0/OCTGN-Setup-3.1.190.0.exe

You might need to change the numbers in order to get the latest release, or open up a webbrowser and download the file yourself(and cd your terminal to the correct folder afterwards)

install OCTGN

WINEPREFIX=~/.wine-octgn wine OCTGN-Setup-3.1.190.0.exe

Just press continue, and OCTGN will try to start up, press yes for the question if you use wine. OCTGN will fail to load. Wait 1-2 min untill no more new messages show in your terminal window, and control+c to gain back control

This is where it get’s tricky, as some settings work better than others.

cd ~/OCTGN/Config

nano settings.json

You might need to change SSLcerts to true, window transparency to true and hardware enabling to false, this worked for me. Other people report other settings though. try some different combinations

You can start OCTGN with the following command

WINEPREFIX=~/.wine-octgn wine ~/OCTGN/OCTGN/OCTGN.exe

And if you are lazy, save this bash script as OCTGN.sh somewhere wher you can find it, and double click to execute

#!/bin/bash
WINEPREFIX=~/.wine-octgn wine ~/OCTGN/OCTGN/OCTGN.exe

If you still can’t load OCTGN, check your terminal for error messages(add --verbose)
What might help

  • Install Samba
  • Install (proprietary) graphic drivers
  • Run wine in windowed mode
  • Install windows fonts

sources:
https://appdb.winehq.org/objectManager.php?sClass=version&iId=28220
https://www.playonlinux.com/en/topic-11630-script_Octgn.html
http://help.octgn.net/support/discussions/topics/4000318653


#2

Please note, if you are running a 32bit system, you won’t need the WINEARCH function, or install the wine32 and i386 architecture


#3

Alternatively you can open a browser and go to www.jinteki.net :sunglasses:


Official Stimhack OCTGN League PART IV
Official Stimhack OCTGN League PART IV
#4

Thank you very much for the guide! I finally found my problem: I had to install samba. Now everything works, regardless of the settings (so with or without ignore ssl, hardware rendering …).

At least on arch linux, to install the .NET framework 4.0 you need to install msxml3. So:

$ WINEPREFIX=~/.wine-octgn winetricks -q msxml3 vcrun2010 dotnet40

See the arch linux wiki. Otherwise it wont install octgn.

And it runs much better than in a VM now. SHL V, here I come!

@mtgred I did, and its awesome. But SHL V won’t allow it, it seems:


#5

cheers and updated, winetricks in the AUR(winetricks-git) or arch depos?


#6

It’s in the official repos.

Personally, I’m just using an XP VM that has OCTGN on it and nothing else. Works fine for me!


#7

I know its in the repo, but a more updated version is in the AUR

plus is corefonts really needed? I can do it without, but then you do get ugly fonts;)


#8

PS:

anyone knows the wget url to always fetch the master version from github? Saves updating the bloody thing everytime a new version comes out